Intereting Posts
Как передать аргумент командной строки в электронном Не удается выполнить POST в nodejs и mongodb в режиме спуска nodejs – Ошибка: вызвать ENOENT при настройке размера изображения с помощью модуля gm браузер (chrome, firefox) jquery .val () не работает для заполненных полей ввода (имя пользователя, пароль) Как запустить protractor как скрипт, а не как дочерний процесс или использовать бегун задачи? Как исправить TypeError: невозможно прочитать свойство ‘name’ из Express Nodemailer Как запустить скрипт приложения Google с помощью Google API Service Library (Node.js) node.js: readSync из stdin? Как отображать данные в формате таблицы в Microsoft Bot babel-node больше не работает в разных каталогах Apache Cordova – удалить глобально Запрос с мангустами и датами Приложение Node.js работает локально, но heroku говорит, что отсутствует модуль Шаги для отправки https-запроса службе restа в узле js Создание подписанных URL-адресов для облачного хранилища Google с использованием NodeJS

Не удалось восстановить зависимости с npm

Поскольку я пытаюсь подтолкнуть мое приложение nodejs, которое отлично работает локально для heroku, вот что я получаю в терминале:

dcaclab@ubuntu:~/RubymineProjects/nodejs_consumer$ git push heroku master Counting objects: 1417, done. Compressing objects: 100% (1195/1195), done. Writing objects: 100% (1417/1417), 2.02 MiB | 22 KiB/s, done. Total 1417 (delta 247), reused 0 (delta 0) -----> Node.js app detected -----> Resolving engine versions Using Node.js version: 0.10.6 Using npm version: 1.2.21 -----> Fetching Node.js binaries -----> Vendoring node into slug -----> Installing dependencies with npm npm WARN package.json node-example@0.0.1 No repository field. npm WARN package.json node-example@0.0.1 No readme data. npm WARN package.json node@0.0.0 No repository field. npm WARN package.json faye-websocket@0.4.0 No repository field. npm WARN package.json faye-websocket@0.4.0 'repositories' (plural) Not supported. npm WARN package.json Please pick one as the 'repository' field npm WARN package.json rbytes@0.0.2 No repository field. npm WARN package.json node-example@0.0.1 No repository field. npm WARN package.json node-example@0.0.1 No readme data. npm WARN package.json node@0.0.0 No repository field. npm WARN package.json faye-websocket@0.4.0 No repository field. npm WARN package.json faye-websocket@0.4.0 'repositories' (plural) Not supported. npm WARN package.json Please pick one as the 'repository' field npm WARN package.json rbytes@0.0.2 No repository field. > weak@0.2.2 install /tmp/build_f86ikz343m5u/node_modules/dnode/node_modules/weak > node-gyp rebuild gyp http GET http://nodejs.org/dist/v0.10.6/node-v0.10.6.tar.gz gyp http 200 http://nodejs.org/dist/v0.10.6/node-v0.10.6.tar.gz make: Entering directory `/tmp/build_f86ikz343m5u/node_modules/dnode/node_modules/weak/build' CXX(target) Release/obj.target/weakref/src/weakref.o SOLINK_MODULE(target) Release/obj.target/weakref.node SOLINK_MODULE(target) Release/obj.target/weakref.node: Finished COPY Release/weakref.node make: Leaving directory `/tmp/build_f86ikz343m5u/node_modules/dnode/node_modules/weak/build' > rbytes@0.0.2 install /tmp/build_f86ikz343m5u/node_modules/shoe/node_modules/sockjs/node_modules/rbytes > node-waf configure build sh: node-waf: not found npm ERR! weird error 127 npm ERR! not ok code 0 ! Failed to rebuild dependencies with npm ! Heroku push rejected, failed to compile Node.js app To git@heroku.com:dcaclab-simulator.git ! [remote rejected] master -> master (pre-receive hook declined) error: failed to push some refs to 'git@heroku.com:dcaclab-simulator.git' 

вот мой файл package.json:

 { "name": "node-example", "version": "0.0.1", "dependencies": { "dnode": "1.0.5", "shoe": "0.0.10" }, "engines": { "node": "0.10.x", "npm": "1.2.x" } } 

Любая идея, пожалуйста?

РЕДАКТИРОВАТЬ

Пытался использовать узел 0.8, вот что я получил:

 dcaclab@ubuntu:~/RubymineProjects/nodejs_consumer$ git push heroku master Counting objects: 1420, done. Compressing objects: 100% (1198/1198), done. Writing objects: 100% (1420/1420), 2.02 MiB | 24 KiB/s, done. Total 1420 (delta 249), reused 0 (delta 0) -----> Node.js app detected -----> Resolving engine versions Using Node.js version: 0.8.23 Using npm version: 1.2.21 -----> Fetching Node.js binaries -----> Vendoring node into slug -----> Installing dependencies with npm npm WARN package.json node-example@0.0.1 No repository field. npm WARN package.json node-example@0.0.1 No readme data. npm WARN package.json node@0.0.0 No repository field. npm WARN package.json rbytes@0.0.2 No repository field. npm WARN package.json faye-websocket@0.4.0 No repository field. npm WARN package.json faye-websocket@0.4.0 'repositories' (plural) Not supported. npm WARN package.json Please pick one as the 'repository' field npm WARN package.json node-example@0.0.1 No repository field. npm WARN package.json node-example@0.0.1 No readme data. npm WARN package.json node@0.0.0 No repository field. npm WARN package.json rbytes@0.0.2 No repository field. npm WARN package.json faye-websocket@0.4.0 No repository field. npm WARN package.json faye-websocket@0.4.0 'repositories' (plural) Not supported. npm WARN package.json Please pick one as the 'repository' field > weak@0.2.2 install /tmp/build_1uw8vrtz5u7yu/node_modules/dnode/node_modules/weak > node-gyp rebuild gyp http GET http://nodejs.org/dist/v0.8.23/node-v0.8.23.tar.gz gyp http 200 http://nodejs.org/dist/v0.8.23/node-v0.8.23.tar.gz make: Entering directory `/tmp/build_1uw8vrtz5u7yu/node_modules/dnode/node_modules/weak/build' CXX(target) Release/obj.target/weakref/src/weakref.o SOLINK_MODULE(target) Release/obj.target/weakref.node SOLINK_MODULE(target) Release/obj.target/weakref.node: Finished COPY Release/weakref.node make: Leaving directory `/tmp/build_1uw8vrtz5u7yu/node_modules/dnode/node_modules/weak/build' > rbytes@0.0.2 install /tmp/build_1uw8vrtz5u7yu/node_modules/shoe/node_modules/sockjs/node_modules/rbytes > node-waf configure build Checking for program g++ or c++ : /usr/bin/g++ Checking for program cpp : /usr/bin/cpp Checking for program ar : /usr/bin/ar Checking for program ranlib : /usr/bin/ranlib Checking for g++ : ok Checking for node path : not found Checking for node prefix : ok /tmp/node-node-Rkll 'configure' finished successfully (0.027s) Waf: Entering directory `/home/dcaclab/RubymineProjects/nodejs_consumer/node_modules/shoe/node_modules/sockjs/node_modules/rbytes/build' Waf: Leaving directory `/home/dcaclab/RubymineProjects/nodejs_consumer/node_modules/shoe/node_modules/sockjs/node_modules/rbytes/build' Traceback (most recent call last): File "/tmp/node-node-Rkll/bin/node-waf", line 16, in  Scripting.prepare(t, os.getcwd(), VERSION, wafdir) File "/tmp/node-node-Rkll/bin/../lib/node/wafadmin/Scripting.py", line 145, in prepare prepare_impl(t, cwd, ver, wafdir) File "/tmp/node-node-Rkll/bin/../lib/node/wafadmin/Scripting.py", line 135, in prepare_impl main() File "/tmp/node-node-Rkll/bin/../lib/node/wafadmin/Scripting.py", line 188, in main fun(ctx) File "/tmp/node-node-Rkll/bin/../lib/node/wafadmin/Scripting.py", line 386, in build return build_impl(bld) File "/tmp/node-node-Rkll/bin/../lib/node/wafadmin/Scripting.py", line 405, in build_impl bld.compile() File "/tmp/node-node-Rkll/bin/../lib/node/wafadmin/Build.py", line 268, in compile os.chdir(self.bldnode.abspath()) OSError: [Errno 2] No such file or directory: '/home/dcaclab/RubymineProjects/nodejs_consumer/node_modules/shoe/node_modules/sockjs/node_modules/rbytes/build' npm ERR! weird error 1 npm ERR! not ok code 0 ! Failed to rebuild dependencies with npm ! Heroku push rejected, failed to compile Node.js app To git@heroku.com:dcaclab-simulator.git ! [remote rejected] master -> master (pre-receive hook declined) error: failed to push some refs to 'git@heroku.com:dcaclab-simulator.git' 

Таким rbytes пакет rbytes не изменился в течение 2 лет, и в это время узел переключился с системы сборки node-gyp на node-gyp . Начиная с узла v0.10.0 , node-waf больше не включается, поэтому сообщение sh: node-waf: not found . Я думаю, у вас есть несколько вариантов (в порядке предпочтения):

  1. Используйте более современный модуль вместо rbytes
  2. Убедить автора rbytes обновить для поддержки последнего узла и выпуска новой версии
  3. Вилки-рибы и исправить сами
  4. Установите свой пакет package.json на узел 0.8 и повторите попытку

РЕДАКТИРОВАТЬ

Ну, сообщение об ошибке # 2 по-прежнему выглядит так: ряды не строятся должным образом. Мне пришлось бы вникнуть в этот пакет, особенно для понимания ошибки. Не знаете, как / почему он работает для вас локально, но имеет проблемы с героку, но я думаю, что настало время для поддерживающего rbytes выполнить некоторое обслуживание.

У меня была эта проблема после нового компилята последней версии node.js в Ubuntu. Согласно совету Питера Лиона, проблема связана с тем, что node-gyp не существует. Обычно при установке из предварительно скомпилированного пакета это не проблема (aptitude и rhel repos обычно include node-gyp по умолчанию).

Однако, если вы строите из источника, скорее всего, node-gyp не существует, что и вызвало проблему в моем случае.

Это решило это для меня:

 sudo npm install -g node-gyp 

После этого работа с npm install работала нормально, ошибки исчезли!

Держитесь подальше от rbytes и вообще от любого не поддерживаемого модуля, особенно, делая что-то важное и тонкое, как крипто. Вы можете получить все необходимое, используя собственный криптографический модуль Node. См. http://nodejs.org/api/crypto.html#crypto_crypto_randombytes_size_callback :

 crypto.pseudoRandomBytes(256) 

Я столкнулся с такой же проблемой, просто удалив существующий каталог node_module. а затем запустите npm install. это оно