npm install создает огромный список ошибок

Я должен сформулировать этот вопрос, сказав, что я действительно новичок в Angular и Node. Следуя указаниям этого урока Tuts + , я клонировал образец Angular repo и затем запускал npm install . Это дало массивный список ошибок, а затем оставило мой терминал висящим около 5 минут. После этого я запустил npm start и открыл пример приложения, которое, казалось, функционировало просто отлично.

Как я уже сказал, я очень новичок в Angular и Node, поэтому я не знаю, как отлаживать ошибки, которые я вижу, или если это даже то, о чем я должен беспокоиться. Любое понимание было бы очень полезно. Спасибо!

npm install журнал: https://gist.github.com/danielbonnell/30959bd15297f1f4ab43

 ➜ angular-seed git:(master) npm install npm WARN engine karma@0.10.10: wanted: {"node":"~0.8 || ~0.10"} (current: {"node":"0.12.2","npm":"2.7.5"}) npm WARN peerDependencies The peer dependency karma-jasmine@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-requirejs@~0.2.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-coffee-preprocessor@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-html2js-preprocessor@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-chrome-launcher@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-firefox-launcher@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-phantomjs-launcher@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. npm WARN peerDependencies The peer dependency karma-script-launcher@~0.1.0 included from karma will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. > fsevents@0.2.1 install /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma/node_modules/chokidar/node_modules/fsevents > node-gyp rebuild CXX(target) Release/obj.target/fse/fsevents.o In file included from ../fsevents.cc:6: ../node_modules/nan/nan.h:339:13: error: no member named 'New' in 'v8::String' return _NAN_ERROR(v8::Exception::Error, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:319:50: note: expanded from macro '_NAN_ERROR' # define _NAN_ERROR(fun, errmsg) fun(v8::String::New(errmsg)) ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:343:5: error: no member named 'ThrowException' in namespace 'v8' _NAN_THROW_ERROR(v8::Exception::Error, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:324:11: note: expanded from macro '_NAN_THROW_ERROR' v8::ThrowException(_NAN_ERROR(fun, errmsg)); \ ~~~~^ ../node_modules/nan/nan.h:343:5: error: no member named 'New' in 'v8::String' _NAN_THROW_ERROR(v8::Exception::Error, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:324:26: note: expanded from macro '_NAN_THROW_ERROR' v8::ThrowException(_NAN_ERROR(fun, errmsg)); \ ^~~~~~~~~~~~~~~~~~~~~~~ macro '_NAN_ERROR'n/nan.h:319:50: note: expanded from - # define _NAN_ERROR(fun, errmsg) fun(v8::String::New(errmsg)) ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:348:9: error: no type named 'ThrowException' in namespace 'v8' v8::ThrowException(error); ~~~~^ ../node_modules/nan/nan.h:355:65: error: no member named 'New' in 'v8::String' v8::Local err = v8::Exception::Error(v8::String::New(msg)); ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:357:26: error: no member named 'New' in 'v8::String' obj->Set(v8::String::New("code"), v8::Int32::New(errorNumber)); ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:357:65: error: too few arguments to function call, expected 2, have 1 obj->Set(v8::String::New("code"), v8::Int32::New(errorNumber)); ~~~~~~~~~~~~~~ ^ /Users/ACIDSTEALTH/.node-gyp/0.12.2/deps/v8/include/v8.h:2012:3: note: 'New' declared here static Local New(Isolate* isolate, int32_t value); ^ In file included from ../fsevents.cc:6: ../node_modules/nan/nan.h:369:12: error: no member named 'New' in 'v8::String' return _NAN_ERROR(v8::Exception::TypeError, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:319:50: note: expanded from macro '_NAN_ERROR' # define _NAN_ERROR(fun, errmsg) fun(v8::String::New(errmsg)) ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:373:5: error: no member named 'ThrowException' in namespace 'v8' _NAN_THROW_ERROR(v8::Exception::TypeError, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:324:11: note: expanded from macro '_NAN_THROW_ERROR' v8::ThrowException(_NAN_ERROR(fun, errmsg)); \ ~~~~^ ../node_modules/nan/nan.h:373:5: error: no member named 'New' in 'v8::String' _NAN_THROW_ERROR(v8::Exception::TypeError, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:324:26: note: expanded from macro '_NAN_THROW_ERROR' v8::ThrowException(_NAN_ERROR(fun, errmsg)); \ ^~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:319:50: note: expanded from macro '_NAN_ERROR' # define _NAN_ERROR(fun, errmsg) fun(v8::String::New(errmsg)) ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:377:12: error: no member named 'New' in 'v8::String' return _NAN_ERROR(v8::Exception::RangeError, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:319:50: note: expanded from macro '_NAN_ERROR' # define _NAN_ERROR(fun, errmsg) fun(v8::String::New(errmsg)) ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:381:5: error: no member named 'ThrowException' in namespace 'v8' _NAN_THROW_ERROR(v8::Exception::RangeError, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:324:11: note: expanded from macro '_NAN_THROW_ERROR' v8::ThrowException(_NAN_ERROR(fun, errmsg)); \ ~~~~^ ../node_modules/nan/nan.h:381:5: error: no member named 'New' in 'v8::String' _NAN_THROW_ERROR(v8::Exception::RangeError, errmsg); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:324:26: note: expanded from macro '_NAN_THROW_ERROR' v8::ThrowException(_NAN_ERROR(fun, errmsg)); \ ^~~~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:319:50: note: expanded from macro '_NAN_ERROR' # define _NAN_ERROR(fun, errmsg) fun(v8::String::New(errmsg)) ~~~~~~~~~~~~^ ../node_modules/nan/nan.h:727:49: error: too few arguments to function call, single argument 'isolate' was not specified v8::Local obj = v8::Object::New(); ~~~~~~~~~~~~~~~ ^ /Users/ACIDSTEALTH/.node-gyp/0.12.2/deps/v8/include/v8.h:2388:3: note: 'New' declared here static Local New(Isolate* isolate); ^ In file included from ../fsevents.cc:6: ../node_modules/nan/nan.h:733:49: error: too few arguments to function call, single argument 'isolate' was not specified v8::Local obj = v8::Object::New(); ~~~~~~~~~~~~~~~ ^ /Users/ACIDSTEALTH/.node-gyp/0.12.2/deps/v8/include/v8.h:2388:3: note: 'New' declared here static Local New(Isolate* isolate); ^ In file included from ../fsevents.cc:6: ../node_modules/nan/nan.h:740:12: error: no member named 'Dispose' in 'v8::Persistent<v8::Object, v8::NonCopyablePersistentTraits >' handle.Dispose(); ~~~~~~ ^ ../node_modules/nan/nan.h:741:12: error: no member named 'Clear' in 'v8::Persistent<v8::Object, v8::NonCopyablePersistentTraits >' handle.Clear(); ~~~~~~ ^ ../node_modules/nan/nan.h:746:39: error: no member named 'NewSymbol' in 'v8::String'; did you mean 'IsSymbol'? NanPersistentToLocal(handle)->Set(NanSymbol("callback"), fn); ^~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:181:38: note: expanded from macro 'NanSymbol' #define NanSymbol(value) v8::String::NewSymbol(value) ~~~~~~~~~~~~^ /Users/ACIDSTEALTH/.node-gyp/0.12.2/deps/v8/include/v8.h:1379:8: note: 'IsSymbol' declared here bool IsSymbol() const; ^ In file included from ../fsevents.cc:6: ../node_modules/nan/nan.h:746:39: error: call to non-static member function without an object argument NanPersistentToLocal(handle)->Set(NanSymbol("callback"), fn); ^~~~~~~~~~~~~~~~~~~~~ ../node_modules/nan/nan.h:181:38: note: expanded from macro 'NanSymbol' #define NanSymbol(value) v8::String::NewSymbol(value) ~~~~~~~~~~~~^~~~~~~~~ fatal error: too many errors emitted, stopping now [-ferror-limit=] 20 errors generated. make: *** [Release/obj.target/fse/fsevents.o] Error 1 gyp ERR! build error gyp ERR! stack Error: `make` failed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:269:23) gyp ERR! stack at ChildProcess.emit (events.js:110:17) gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:1074:12) gyp ERR! System Darwin 14.3.0 gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma/node_modules/chokidar/node_modules/fsevents gyp ERR! node -v v0.12.2 gyp ERR! node-gyp -v v1.0.3 gyp ERR! not ok npm WARN optional dep failed, continuing fsevents@0.2.1 > ws@0.4.32 install /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws > (node-gyp rebuild 2> builderror.log) || (exit 0) CXX(target) Release/obj.target/bufferutil/src/bufferutil.o SOLINK_MODULE(target) Release/bufferutil.node SOLINK_MODULE(target) Release/bufferutil.node: Finished CXX(target) Release/obj.target/validation/src/validation.o SOLINK_MODULE(target) Release/validation.node SOLINK_MODULE(target) Release/validation.node: Finished npm WARN peerDependencies The peer dependency requirejs@~2.1 included from karma-requirejs will no npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly. \ > phantomjs@1.9.16 install /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma-phantomjs-launcher/node_modules/phantomjs > node install.js PhantomJS detected, but wrong version 2.0.0 @ /usr/local/bin/phantomjs. Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-macosx.zip Saving to /var/folders/bq/g95dzyzn6nv074fpfhz2tjkh0000gn/T/phantomjs/phantomjs-1.9.8-macosx.zip Receiving... [========================----------------] 60% 0.0s Received 9187K total. Extracting zip contents Removing /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma-phantomjs-launcher/node_modules/phantomjs/lib/phantom Copying extracted folder /var/folders/bq/g95dzyzn6nv074fpfhz2tjkh0000gn/T/phantomjs/phantomjs-1.9.8-macosx.zip-extract-1429227494807/phantomjs-1.9.8-macosx -> /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma-phantomjs-launcher/node_modules/phantomjs/lib/phantom Writing location.js file Done. Phantomjs binary available at /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed/node_modules/karma-phantomjs-launcher/node_modules/phantomjs/lib/phantom/bin/phantomjs > angular-seed@0.0.0 postinstall /Users/ACIDSTEALTH/Dropbox/Launch_Academy/angular-seed > bower install bower html5-boilerplate#~4.3.0 not-cached git://github.com/h5bp/html5-boilerplate.git#~4.3.0 bower html5-boilerplate#~4.3.0 resolve git://github.com/h5bp/html5-boilerplate.git#~4.3.0 bower angular-route#1.2.x not-cached git://github.com/angular/bower-angular-route.git#1.2.x bower angular-route#1.2.x resolve git://github.com/angular/bower-angular-route.git#1.2.x bower angular-loader#1.2.x not-cached git://github.com/angular/bower-angular-loader.git#1.2.x bower angular-loader#1.2.x resolve git://github.com/angular/bower-angular-loader.git#1.2.x bower angular-mocks#~1.2.x not-cached git://github.com/angular/bower-angular-mocks.git#~1.2.x bower angular-mocks#~1.2.x resolve git://github.com/angular/bower-angular-mocks.git#~1.2.x bower angular#1.2.x not-cached git://github.com/angular/bower-angular.git#1.2.x bower angular#1.2.x resolve git://github.com/angular/bower-angular.git#1.2.x bower html5-boilerplate#~4.3.0 download https://github.com/h5bp/html5-boilerplate/archive/v4.3.0.tar.gz bower angular-mocks#~1.2.x download https://github.com/angular/bower-angular-mocks/archive/v1.2.28.tar.gz bower angular#1.2.x download https://github.com/angular/bower-angular/archive/v1.2.28.tar.gz bower angular-route#1.2.x download https://github.com/angular/bower-angular-route/archive/v1.2.28.tar.gz bower angular-loader#1.2.x download https://github.com/angular/bower-angular-loader/archive/v1.2.28.tar.gz bower html5-boilerplate#~4.3.0 extract archive.tar.gz bower angular-mocks#~1.2.x extract archive.tar.gz bower angular-loader#1.2.x extract archive.tar.gz bower angular-route#1.2.x extract archive.tar.gz bower angular-mocks#~1.2.x resolved git://github.com/angular/bower-angular-mocks.git#1.2.28 bower angular#1.2.x extract archive.tar.gz bower angular-loader#1.2.x resolved git://github.com/angular/bower-angular-loader.git#1.2.28 bower angular-route#1.2.x resolved git://github.com/angular/bower-angular-route.git#1.2.28 bower angular#1.2.x resolved git://github.com/angular/bower-angular.git#1.2.28 bower html5-boilerplate#~4.3.0 invalid-meta html5-boilerplate is missing "main" entry in bower.json bower html5-boilerplate#~4.3.0 invalid-meta html5-boilerplate is missing "ignore" entry in bower.json bower html5-boilerplate#~4.3.0 resolved git://github.com/h5bp/html5-boilerplate.git#4.3.0 bower angular-mocks#~1.2.x install angular-mocks#1.2.28 bower angular-loader#1.2.x install angular-loader#1.2.28 bower angular-route#1.2.x install angular-route#1.2.28 bower angular#1.2.x install angular#1.2.28 bower html5-boilerplate#~4.3.0 install html5-boilerplate#4.3.0 angular-mocks#1.2.28 app/bower_components/angular-mocks └── angular#1.2.28 angular-loader#1.2.28 app/bower_components/angular-loader └── angular#1.2.28 angular-route#1.2.28 app/bower_components/angular-route └── angular#1.2.28 angular#1.2.28 app/bower_components/angular html5-boilerplate#4.3.0 app/bower_components/html5-boilerplate karma-junit-reporter@0.2.2 node_modules/karma-junit-reporter └── xmlbuilder@0.4.2 shelljs@0.2.6 node_modules/shelljs http-server@0.6.1 node_modules/http-server ├── opener@1.3.0 ├── colors@0.6.2 ├── portfinder@0.2.1 (mkdirp@0.0.7) ├── optimist@0.5.2 (wordwrap@0.0.2) ├── ecstatic@0.4.13 (ent@0.0.7, mime@1.2.11, optimist@0.3.7) └── union@0.3.8 (pkginfo@0.2.3, qs@0.5.6) protractor@1.8.0 node_modules/protractor ├── jasminewd@1.1.0 ├── jasminewd2@0.0.2 ├── saucelabs@0.1.1 ├── html-entities@1.1.2 ├── q@1.0.0 ├── minijasminenode@1.1.1 ├── adm-zip@0.4.4 ├── optimist@0.6.1 (wordwrap@0.0.2, minimist@0.0.10) ├── source-map-support@0.2.10 (source-map@0.1.32) ├── glob@3.2.11 (inherits@2.0.1, minimatch@0.3.0) ├── accessibility-developer-tools@2.6.0 ├── lodash@2.4.1 ├── request@2.36.0 (aws-sign2@0.5.0, forever-agent@0.5.2, json-stringify-safe@5.0.0, qs@0.6.6, tunnel-agent@0.4.0, oauth-sign@0.3.0, mime@1.2.11, node-uuid@1.4.3, tough-cookie@0.12.1, form-data@0.1.4, http-signature@0.10.1, hawk@1.0.0) ├── jasmine@2.1.1 (jasmine-core@2.1.3) └── selenium-webdriver@2.44.0 (tmp@0.0.24, xml2js@0.4.4) bower@1.4.1 node_modules/bower ├── is-root@1.0.0 ├── junk@1.0.1 ├── stringify-object@1.0.1 ├── abbrev@1.0.5 ├── user-home@1.1.1 ├── chmodr@0.1.0 ├── which@1.0.9 ├── rimraf@2.3.2 ├── archy@1.0.0 ├── opn@1.0.1 ├── bower-logger@0.2.2 ├── bower-endpoint-parser@0.2.2 ├── graceful-fs@3.0.6 ├── lockfile@1.0.0 ├── lru-cache@2.6.1 ├── nopt@3.0.1 ├── retry@0.6.1 ├── tmp@0.0.24 ├── q@1.2.0 ├── request-progress@0.3.1 (throttleit@0.0.2) ├── shell-quote@1.4.3 (array-filter@0.0.1, array-map@0.0.0, array-reduce@0.0.0, jsonify@0.0.0) ├── chalk@1.0.0 (escape-string-regexp@1.0.3, ansi-styles@2.0.1, supports-color@1.3.1, strip-ansi@2.0.1, has-ansi@1.0.3) ├── bower-json@0.4.0 (intersect@0.0.3, deep-extend@0.2.11, graceful-fs@2.0.3) ├── semver@2.3.2 ├── fstream@1.0.4 (inherits@2.0.1) ├── p-throttler@0.1.1 (q@0.9.7) ├── promptly@0.2.0 (read@1.0.5) ├── mkdirp@0.5.0 (minimist@0.0.8) ├── tar-fs@1.5.0 (pump@1.0.0, tar-stream@1.1.3) ├── fstream-ignore@1.0.2 (inherits@2.0.1, minimatch@2.0.4) ├── glob@4.5.3 (inherits@2.0.1, inflight@1.0.4, once@1.3.1, minimatch@2.0.4) ├── insight@0.5.3 (object-assign@2.0.0, lodash.debounce@3.0.3, async@0.9.0, os-name@1.0.3, tough-cookie@0.12.1) ├── update-notifier@0.3.2 (is-npm@1.0.0, string-length@1.0.0, semver-diff@2.0.0, latest-version@1.0.0) ├── decompress-zip@0.1.0 (mkpath@0.1.0, touch@0.0.3, readable-stream@1.1.13, binary@0.3.0) ├── github@0.2.3 ├── bower-registry-client@0.3.0 (graceful-fs@2.0.3, request-replay@0.2.0, rimraf@2.2.8, lru-cache@2.3.1, async@0.2.10, mkdirp@0.3.5, request@2.51.0) ├── cardinal@0.4.4 (ansicolors@0.2.1, redeyed@0.4.4) ├── request@2.53.0 (caseless@0.9.0, json-stringify-safe@5.0.0, forever-agent@0.5.2, aws-sign2@0.5.0, stringstream@0.0.4, oauth-sign@0.6.0, tunnel-agent@0.4.0, isstream@0.1.2, qs@2.3.3, node-uuid@1.4.3, combined-stream@0.0.7, form-data@0.2.0, mime-types@2.0.10, bl@0.9.4, http-signature@0.10.1, tough-cookie@0.12.1, hawk@2.3.1) ├── bower-config@0.6.1 (osenv@0.0.3, graceful-fs@2.0.3, optimist@0.6.1, mout@0.9.1) ├── mout@0.11.0 ├── handlebars@2.0.0 (optimist@0.3.7, uglify-js@2.3.6) ├── configstore@0.3.2 (object-assign@2.0.0, xdg-basedir@1.0.1, osenv@0.1.0, uuid@2.0.1, js-yaml@3.2.7) └── inquirer@0.8.0 (figures@1.3.5, ansi-regex@1.1.1, mute-stream@0.0.4, through@2.3.7, readline2@0.1.1, lodash@2.4.1, rx@2.5.2, cli-color@0.3.3, chalk@0.5.1) karma-firefox-launcher@0.1.4 node_modules/karma-firefox-launcher karma-script-launcher@0.1.0 node_modules/karma-script-launcher karma-html2js-preprocessor@0.1.0 node_modules/karma-html2js-preprocessor karma-jasmine@0.1.5 node_modules/karma-jasmine karma-chrome-launcher@0.1.8 node_modules/karma-chrome-launcher └── which@1.0.9 requirejs@2.1.17 node_modules/requirejs karma-requirejs@0.2.2 node_modules/karma-requirejs karma-coffee-preprocessor@0.1.3 node_modules/karma-coffee-preprocessor └── coffee-script@1.7.1 (mkdirp@0.3.5) karma-phantomjs-launcher@0.1.4 node_modules/karma-phantomjs-launcher └── phantomjs@1.9.16 (which@1.0.9, progress@1.1.8, kew@0.4.0, request-progress@0.3.1, adm-zip@0.4.4, npmconf@2.1.1, request@2.42.0, fs-extra@0.16.5) karma@0.10.10 node_modules/karma ├── di@0.0.1 ├── graceful-fs@1.2.3 ├── colors@0.6.0-1 ├── rimraf@2.1.4 ├── mime@1.2.11 ├── q@0.9.7 ├── glob@3.1.21 (inherits@1.0.0) ├── minimatch@0.2.14 (sigmund@1.0.0, lru-cache@2.6.1) ├── optimist@0.3.7 (wordwrap@0.0.2) ├── coffee-script@1.6.3 ├── lodash@1.1.1 ├── log4js@0.6.23 (async@0.2.10, underscore@1.8.2, readable-stream@1.0.33, semver@4.3.3) ├── http-proxy@0.10.4 (colors@0.6.2, pkginfo@0.3.0, optimist@0.6.1, utile@0.2.1) ├── chokidar@0.8.4 (recursive-readdir@0.0.2) ├── connect@2.8.8 (methods@0.0.1, uid2@0.0.2, pause@0.0.1, cookie-signature@1.0.1, qs@0.6.5, fresh@0.2.0, bytes@0.2.0, buffer-crc32@0.2.1, cookie@0.1.0, send@0.1.4, debug@2.1.3, formidable@1.0.14) ├── useragent@2.0.10 (lru-cache@2.2.4) └── socket.io@0.9.17 (base64id@0.1.0, policyfile@0.0.4, redis@0.7.3, socket.io-client@0.9.16) 

Карма 0.10 несовместима с узлом 0.12

npm WARN engine karma@0.10.10: wanted: {"node":"~0.8 || ~0.10"} (current: {"node":"0.12.2","npm":"2.7.5"})

Переключитесь на версию узла 0.10, и установка, вероятно, сработает.

Если я правильно понял ваш вопрос, причина, по которой вы получили ошибки, заключается в том, что ваша версия Node.js не совпадает с Angular.js

 karma@0.10.10: wanted: {"node":"~0.8 || ~0.10"} (current: {"node":"0.12.2","npm":"2.7.5"}) 

есть два способа исправить вашу проблему

  1. Обновите версию Node.js для соответствия с Angular.js
  2. Установите nvm для переключения версии Node.js

но я предлагаю вам попробовать последний, поскольку это простой способ управлять версией Node.js с помощью nvm .

хотел : {"node":"~0.8 || ~0.10"} ( текущий : { "node":"0.12.2" , “npm”: “2.7.5”})

В соответствии с сообщением вам необходимо понизить пакет node , поскольку пакет несовместим с новейшим node . Этого можно достичь с помощью следующих команд:

 npm install -gn n 0.10.44 node --version 

Пакет n интерактивно управляет всеми версиями вашего узла.

Чтобы вернуться к последнему, запустите: n latest .